Enter forum description here ...

Add Comments Section

Jay 12 months ago 0

I was wondering about adding a comments section for each page? I have one I'm developing for my internal team, but it seems that being able to have discussions without updating the wiki page itself would be a useful feature.


Custom Image Size

Bryan Livingston 2 years ago 0

There needs to be a way to set custom image sizes, or this wiki is useless to me.

There's a proposal to add sizes to CommonMark spec here: https://github.com/jgm/CommonMark/wiki/Deployed-Extensions#image-size

Can't believe that's not in there already. There's a thread with some asshats dissing the idea over at https://talk.commonmark.org/t/support-for-image-dimensions/148/7

There's extensive support for images sizes on Wikipedia that you can see here:



Help needed to get roadkill to work on linux/mono

TW Bert 3 years ago • updated 3 years ago 4
Roadkill seems pretty good for my needs, and I like the techniques used. By seeing the mono zipfiles for download (great), I guess that they are tested (at least basically) but I can't find much info on this. So I tried myself.

Te last two days I spent quite some time to get roadkill to work in linux+mono, to no success alas.
I tried the two downloadable .zip files (roadkill 1.6 and roadkill 2.0), and followed the instruction on http://www.roadkillwiki.net/wiki/15/installing-on-linux-ubuntu-with-mono with minor alterations (version number).
I have apache2 and mono and asp.net running, and mongodb 2.6.4.
3.2.8 (Debian 3.2.8+dfsg-4ubuntu1); ASP.NET Version: 4.0.30319.17020
roadkill 1.6 works a little bit. I get the admin pages, I can connect to mongodb, fill in the next pages, all checks are okay, but at the final 'Next' nothing happens. I can't see anything in any log file.
If I afterwards set installed to True, I do indeed get an empty roadkill wiki. But I can't log in as Admin, and can't add new pages. Clicking on 'forgot my e-mail' gives 'unknown e-mail'.
roadkill 2.0 does not work at all. I temporarily set <customErrors mode="Off"/> , to see what the initial error is, and it's:


Could not load file or assembly or one of its dependencies.

HTTP 500.Error processing request.
Non-web exception. Exception origin (name of application or object): mscorlib.
Exception stack trace:
at (wrapper managed-to-native) System.Reflection.MonoMethodInfo:get_parameter_info (intptr,System.Reflection.MemberInfo)
at System.Reflection.MonoMethodInfo.GetParametersInfo (IntPtr handle, System.Reflection.MemberInfo member) [0x00000] in <filename unknown>:0
at System.Reflection.MonoCMethod.GetParameters () [0x00000] in <filename unknown>:0
at StructureMap.Graph.Constructor.CanBeAutoFilled () [0x00000] in <filename unknown>:0
at StructureMap.Graph.Plugin.get_CanBeAutoFilled () [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginFamily.<discoverImplicitInstances>b__e (System.String key, StructureMap.Graph.Plugin plugin) [0x00000] in <filename unknown>:0
at StructureMap.Util.Cache`2[System.String,StructureMap.Graph.Plugin].Each (System.Action`2 action) [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginFamily.discoverImplicitInstances () [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginFamily.Seal () [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginGraph.<Seal>b__3 (StructureMap.Graph.PluginFamily family) [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginFamilyCollection.Each (System.Action`1 action) [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginGraph.Seal () [0x00000] in <filename unknown>:0
at StructureMap.PluginGraphBuilder.Build () [0x00000] in <filename unknown>:0
at StructureMap.ConfigurationExpression.BuildGraph () [0x00000] in <filename unknown>:0
at StructureMap.ObjectFactory.Initialize (System.Action`1 action) [0x00000] in <filename unknown>:0
at Roadkill.Core.DI.DependencyManager.Configure () [0x00000] in <filename unknown>:0
at Roadkill.Core.RoadkillApplication.Application_Start () [0x00000] in <filename unknown>:0
at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
Version Information:
3.2.8 (Debian 3.2.8+dfsg-4ubuntu1); ASP.NET Version:

Now I'm stuck, does anyone have a clue? No idea what file it's looking for.

Not a bug

Do something about the instant log out

Angarato Surion 2 years ago • updated by Chris 2 years ago 1
Do something about the instant log out

make a theme that displays correctly on IE7/8

Michael Hafner 4 years ago • updated by Chris 4 years ago 1
We use IE at work. I love Road Kill wiki but none of the themes show up correctly in IE. Buttons are missing icons, search box has no label or watermark or other strange formatting issues.

code formating is not working br after line is not good

Piotr Truskolaski 4 years ago 0
code formating is not working br after line is not good

Port it to asp.net identity

Angarato Surion 2 years ago • updated by Chris 2 years ago 2
Port it to asp.net identity

Medium trust support

Chris 4 years ago • updated by Joel McBeth 2 years ago 3

Add support for Medium trust host providers (GoDaddy, 1&1).

Chris 4 years ago
Medium trust is not going to be supported, as Microsoft no longer support it:


CAS integration

fraze9 3 years ago 0
I would love for Road Kill to be able to integrate with CAS Authentication.

user overview: click on an user

unclear 4 years ago 0
on SiteSettings/UserManagement, let me click on a username and show his edits. (just like from history of a page).