0
Answered

Help needed to get roadkill to work on linux/mono

TW Bert 3 years ago • updated 3 years ago 4
Roadkill seems pretty good for my needs, and I like the techniques used. By seeing the mono zipfiles for download (great), I guess that they are tested (at least basically) but I can't find much info on this. So I tried myself.

Te last two days I spent quite some time to get roadkill to work in linux+mono, to no success alas.
I tried the two downloadable .zip files (roadkill 1.6 and roadkill 2.0), and followed the instruction on http://www.roadkillwiki.net/wiki/15/installing-on-linux-ubuntu-with-mono with minor alterations (version number).
I have apache2 and mono and asp.net running, and mongodb 2.6.4.
3.2.8 (Debian 3.2.8+dfsg-4ubuntu1); ASP.NET Version: 4.0.30319.17020
roadkill 1.6 works a little bit. I get the admin pages, I can connect to mongodb, fill in the next pages, all checks are okay, but at the final 'Next' nothing happens. I can't see anything in any log file.
If I afterwards set installed to True, I do indeed get an empty roadkill wiki. But I can't log in as Admin, and can't add new pages. Clicking on 'forgot my e-mail' gives 'unknown e-mail'.
roadkill 2.0 does not work at all. I temporarily set <customErrors mode="Off"/> , to see what the initial error is, and it's:

System.IO.FileNotFoundException

Could not load file or assembly or one of its dependencies.

Description:
HTTP 500.Error processing request.
Details:
Non-web exception. Exception origin (name of application or object): mscorlib.
Exception stack trace:
at (wrapper managed-to-native) System.Reflection.MonoMethodInfo:get_parameter_info (intptr,System.Reflection.MemberInfo)
at System.Reflection.MonoMethodInfo.GetParametersInfo (IntPtr handle, System.Reflection.MemberInfo member) [0x00000] in <filename unknown>:0
at System.Reflection.MonoCMethod.GetParameters () [0x00000] in <filename unknown>:0
at StructureMap.Graph.Constructor.CanBeAutoFilled () [0x00000] in <filename unknown>:0
at StructureMap.Graph.Plugin.get_CanBeAutoFilled () [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginFamily.<discoverImplicitInstances>b__e (System.String key, StructureMap.Graph.Plugin plugin) [0x00000] in <filename unknown>:0
at StructureMap.Util.Cache`2[System.String,StructureMap.Graph.Plugin].Each (System.Action`2 action) [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginFamily.discoverImplicitInstances () [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginFamily.Seal () [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginGraph.<Seal>b__3 (StructureMap.Graph.PluginFamily family) [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginFamilyCollection.Each (System.Action`1 action) [0x00000] in <filename unknown>:0
at StructureMap.Graph.PluginGraph.Seal () [0x00000] in <filename unknown>:0
at StructureMap.PluginGraphBuilder.Build () [0x00000] in <filename unknown>:0
at StructureMap.ConfigurationExpression.BuildGraph () [0x00000] in <filename unknown>:0
at StructureMap.ObjectFactory.Initialize (System.Action`1 action) [0x00000] in <filename unknown>:0
at Roadkill.Core.DI.DependencyManager.Configure () [0x00000] in <filename unknown>:0
at Roadkill.Core.RoadkillApplication.Application_Start () [0x00000] in <filename unknown>:0
at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
Version Information:
3.2.8 (Debian 3.2.8+dfsg-4ubuntu1); ASP.NET Version:
4.0.30319.17020


Now I'm stuck, does anyone have a clue? No idea what file it's looking for.


Under review
Could you repost this on the Roadkill Google group? That's a better place to get help
Will be answered
Hi Chris, thanks for the advice. In the meantime, I managed to get 1.6 + mongo working. Turned out to be a bug in the roadkill asp setup pages (workaround: manually edit the Web.config connection string while the setup page is running, and before step5).

No luck with roadkill 2.0 yet. I suspect mono3 incompatibility with mvc 4.5 (http://www.mono-project.com/docs/about-mono/compatibility/ ) , but haven't looked into it yet. That incompatibily would have been introduced at changeset 60686a123407 of the hg bitbucket repo.

But, I'm not hundred percent sure if roadkill suits our needs, even with 2.0+ .

When I pick this up again, I'll use the google group.